[dm-crypt] aes-ni

Lurkos lurkos.usenet at gmail.com
Sun Oct 16 19:21:10 CEST 2011


*Milan Broz* wrote:

>> Does cryptsetup (with luks volumes) support AES-NI for newer Intel and
>> AMD powered computers?
>
> yes. (in fact it is cryptoAPI which need proper module loaded, not dmcrypt)
> aes-ni has higher priority, so it should be used automatically if available.
>
> btw I just read this
> http://www.phoronix.com/scan.php?page=article&item=intel_aesni_dmcrypt

It seems it's just a matter of loading the "aesni_intel" module.
I cannot understand if there is a switch to select the module to be used
by the crytoAPI.
Maybe aesni_intel supersedes aes_x86_64 once loaded?

-- 
Lurkos




More information about the dm-crypt mailing list