[dm-crypt] [ANNOUNCE] cryptsetup 1.6.0-rc1

Matthias Schniedermeyer ms at citd.de
Sat Dec 29 23:24:38 CET 2012


On 29.12.2012 22:40, Milan Broz wrote:
> 
>    WARNING: benchmark requires kernel userspace crypto API to be available
>    (kernel af_alg and algif_skcipher modules, introduced in  Linux  kernel 2.6.38).

This message doesn't help at all when you have a kernel that doesn't 
have it enabled and thus you can't find any module by that name. (And 
you CAN have a kernel with it build in, no module in that case too)

The option for algif_skcipher is:
CONFIG_CRYPTO_USER_API_SKCIPHER
"Cryptographic API" -> "User-space interface for symmetric key cipher algorithms"

The other option (that is responsible for af_alg) is hidden and 
automatically 'select'ed by activating the option above.




-- 

Matthias


More information about the dm-crypt mailing list