[dm-crypt] ioctl missing

Benoît Kuhn benoit.ku at gmail.com
Tue Jul 24 11:23:35 CEST 2012


Hi,

I hope that you can help me, I am working with thin clients on ThinStation
distribution. I would like to integrate cryptsetup with luks extension in
this OS to open encrypted partitions (in my case, a partition on an USB
stick). So I compiled the last version of cryptsetup available on CRUX. I
included also all (I think it's all...) packages needed by cryptsetup.
So here are packages that I have on my OS, Cryptsetup, popt, gettext,
libgcrypt, libdevmapper, util-linux-ng and lvm2. The
library libgpg-error.so.0 is charged automatically when I compile my OS.

My problem is when I start my OS and try to launch the command "cryptsetup
luksOpen /dev/devicename nameoflocation", it asks me the passphrase and
after having enter anything (I mean whatever the password, if it is good or
wrong), I have the following message "device-mapper: reload ioctl failde:
No such file or directory".

So I compared the following command my own system (Ubuntu 12.04 LTS i386)
and on ThinStation : "ldd path/cryptsetup" and I obtain 2 more libraries on
my system which are libdl.so.2 (that I have on ThinStation but not yet
associate to cryptsetup) and libselinux.so.1 that doesn't appear on
ThinStation.

I also have the possibility to compile my OS with the option allmodules.
That fix apparently the "ioctl" error but nothing append... I mean that I
enter a password when it asks me and whatever the password nothing append,
it looks like a no and loop during the verification of the password.

Also I tested other luks options but I have the same problem...

If you have any idea, it will be very great! :)

Thank you

Benoit
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.saout.de/pipermail/dm-crypt/attachments/20120724/b592e5d8/attachment.html>


More information about the dm-crypt mailing list