[dm-crypt] Encrypt all partitions with dm-crypt

Matthew Monaco dgbaley27 at 0x01b.net
Tue Sep 25 08:31:24 CEST 2012


On 09/24/2012 09:12 PM, Stayvoid wrote:
> Hi,
> 
> Let's forget about Lemote specific issues.
> 
> For some reason I can't mount my partition when I'm using a USB stick.
> 
> Here is what I did:
> 
> 1. Booted from a USB stick;
> 
> 2. Created a mapping:
> 
>    # cryptsetup -c aes-xts-plain -s 512 -y create main /dev/sda3
> 
> 3. Created a filesystem:
> 
>    # mkfs.ext3 /dev/mapper/main
> 
> 4. Mounted it:
> 
>    # mount -t ext3 /dev/mapper/main /media/parabola
> 
>    It worked fine.
> 
> 5. Unmounted it:
> 
>    # umount /media/parabola
> 
> 6. Detached the partition:
> 
>    # cryptsetup remove main
> 
> Then I tried to use the same partition:
> 
> # cryptsetup create main /dev/sda3

This is your problem. You need

cryptsetup -c aes-xts-plain -s 512 ...

every time you map this device. You can sort of avoid it by using the defaults,
which are listed at the end of

cryptsetup --help

However, if the defaults change, you need to remember those parameters.

This is a big advantage to LUKS, there is a header that remembers everything but
the password.

> # mount -t ext3 /dev/mapper/main /media/parabola
> 
> mount failed.
> 
> "If the password is not correct, the mount command will fail. In this
> case simply remove the map sdc1 (cryptsetup remove sdc1) and create it
> again." [1]
> 
> I'm sure that I was using the right password.
> 
> What is the problem?
> 
> [1] http://sleepyhead.de/howto/?href=cryptpart
> 
> Thanks
> _______________________________________________
> dm-crypt mailing list
> dm-crypt at saout.de
> http://www.saout.de/mailman/listinfo/dm-crypt
> 



More information about the dm-crypt mailing list