[dm-crypt] Building Cryptsetup 1.6.1 on Ubuntu 12.10

Arno Wagner arno at wagner.name
Thu Aug 29 05:40:15 CEST 2013


Just install both in one go:

  apt-get install dmsetup livdevmapper

or the equivalent if you downloaded them manually.

Circular dependencies are fine, they just mean that you 
cannot install the packages seperately.

Arno

On Wed, Aug 28, 2013 at 04:48:28PM -0700, Juan Romano wrote:
> I'm trying to build cryptsetup 1.6.1  on Ubuntu 12.10.
> 
> I am having a problem with the 'libcryptsetup-dev_1.6.1-1_amd64.deb'
> package.
> 
> Following its dependencies, I end up with a circular dependency between
> 'dmsetup 1.02.77-6_amd64.deb'  and 'livdevmapper
> 1.02.1_1.02.77-6_amd64.deb'
> 
>  
> 
> Any help with this is appreciated.
> 
>  
> 
> Thanks.
> 

> _______________________________________________
> dm-crypt mailing list
> dm-crypt at saout.de
> http://www.saout.de/mailman/listinfo/dm-crypt


-- 
Arno Wagner,     Dr. sc. techn., Dipl. Inform.,    Email: arno at wagner.name
GnuPG: ID: CB5D9718  FP: 12D6 C03B 1B30 33BB 13CF  B774 E35C 5FA1 CB5D 9718
----
There are two ways of constructing a software design: One way is to make it
so simple that there are obviously no deficiencies, and the other way is to
make it so complicated that there are no obvious deficiencies. The first
method is far more difficult.  --Tony Hoare


More information about the dm-crypt mailing list