[dm-crypt] [ANNOUNCE] cryptsetup 1.6.0-rc1

Yves-Alexis Perez corsac at debian.org
Sun Jan 6 13:16:12 CET 2013


On dim., 2012-12-30 at 12:40 +0100, Milan Broz wrote:
> On 12/30/2012 11:20 AM, Arno Wagner wrote:
> 
> > Milan: I think presence of if_alg.h should be verified in 
> > the configure script, possibly with a brief explanation what
> > the problem is on fail. The compile-error is a bit obscure.
> 
> TBH, I completely forgot to add this... :)
> 
> Committed to git - by default configure fails with
> ...
> checking linux/if_alg.h usability... no
> checking linux/if_alg.h presence... no
> checking for linux/if_alg.h... no
> configure: error: You need Linux kernel headers with userspace crypto
> interface. (Or use --disable-kernel_crypto.)
> 
> The switch --disable-kernel_crypto completely removes support,
> so you can compile it with old kernel or without kernel headers.
> (But no cipher benchmark and no tcrypt will be available.)

Is this really the proper fix? Usually, userland needing headers more
recent than what's in linux-libc-dev should embed them, and correctly
handle at runtime if the interfaces are available.

What happens here if cryptsetup is built on a recent enough kernel where
the header is present, and then run on an old kernel? Will it fail
gracefully?

Regards,
-- 
Yves-Alexis
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 490 bytes
Desc: This is a digitally signed message part
URL: <http://www.saout.de/pipermail/dm-crypt/attachments/20130106/d3e573e6/attachment.asc>


More information about the dm-crypt mailing list