[dm-crypt] luksAddKey successful but not working

leam hall leamhall at gmail.com
Thu Jun 6 19:41:54 CEST 2013


This seems resolved with an updated version of the kernel.


On Wed, May 22, 2013 at 11:36 AM, leam hall <leamhall at gmail.com> wrote:

> I have a support ticket with RH open now. So far I am not sure it is a
> bug. It may well just be my misunderstanding. If it does turn out to be a
> bug I will file it.
>
> Thanks!
>
> Leam
>
>
> On Wed, May 22, 2013 at 11:28 AM, Milan Broz <gmazyland at gmail.com> wrote:
>
>> On 05/22/2013 04:33 PM, Arno Wagner wrote:
>> > A look into the man-page of cryptsetup shows that luksAddKey does
>> > not write the key-file, but reads it. I am surprised though that
>> > cryptsetup does not complain that the file is missing. With my
>> > system (cryptsetup 1.6.0) it does:
>> >
>> > # cryptsetup luksAddKey /dev/loop0 keyfile
>> > Enter any passphrase:
>> > Failed to open key file.    <---
>> > #
>>
>> RHEL5 has very old cryptsetup (based on 1.0.3 version) and it is
>> impossible
>> to rebase there to a new version.
>> You can create a bug requesting to fix this issue in RH bugzilla though...
>>
>> Milan
>> _______________________________________________
>> dm-crypt mailing list
>> dm-crypt at saout.de
>> http://www.saout.de/mailman/listinfo/dm-crypt
>>
>
>
>
> --
> Mind on a Mission <http://leamhall.blogspot.com/>
>



-- 
Mind on a Mission <http://leamhall.blogspot.com/>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.saout.de/pipermail/dm-crypt/attachments/20130606/800c2311/attachment.html>


More information about the dm-crypt mailing list