[dm-crypt] run cryptsetup-reencrypt failed

Xiao Ni xni at redhat.com
Wed Nov 13 09:54:19 CET 2013


Hi Milan Broz

Sorry reply this so late and I'm busy doing my work about RHEL7. 

----- Original Message -----
> From: "Milan Broz" <gmazyland at gmail.com>
> To: "Xiao Ni" <xni at redhat.com>, dm-crypt at saout.de
> Cc: "Ondrej Kozina" <okozina at redhat.com>
> Sent: Friday, November 8, 2013 6:07:54 AM
> Subject: Re: [dm-crypt] run cryptsetup-reencrypt failed
> 
> 
> On 8.11.2013 11:18, Xiao Ni wrote:
> >     [root at storageqe-06 /]# ./cryptsetup-1.6.2/src/cryptsetup-reencrypt
> >     /dev/dm-10  --debug
> 
> First, NEVER EVER use /dec/dm-X devices directly.
> Always use symbolic links in /dev/mapper or other links, which are not
> dynamic.
> 
> ...
> > open device LUKS-bfeb35f1-90b9-4bc6-ba43-a4302db7957b.new
> > path is LUKS-bfeb35f1-90b9-4bc6-ba43-a4302db7957b.new
> > file path is (null)
> 
> this is strange.
> 
> It creates temporary LUKS headers in file in current directory.
> What filesystem you are using there?

It's xfs.
> 
> 
> > open device LUKS-bfeb35f1-90b9-4bc6-ba43-a4302db7957b.new             //I
> > thinks it should open /dev/loop0
> > path is /dev/loop0
> 
> no, loop should be hidden there.

Thanks for the redress.
> 
> Anyway, could you add this to issues
> http://code.google.com/p/cryptsetup/issues/list
> and add more info about your system?
> 
> I know you are using some complex storage config like multipath, so the best
> way
> will be to discuss it with Ondra (as my former RH colleague) inside RH and
> when you
> have all the info, just report it to issues page.

I have discussed this with Ondra and please let me know if you need more information about this.

> 
> 
> Thanks,
> Milan
> 
> 


More information about the dm-crypt mailing list