[dm-crypt] [PATCH] libdevmapper: correctly compare major and minor versions

Milan Broz gmazyland at gmail.com
Thu Nov 14 08:38:16 CET 2013


On 11/13/2013 10:27 PM, Dave Reisner wrote:
> Previously, this code could incorrectly identify a version of crypt or
> dm due to the way it compared versions. For example, if a feature was
> gated on crypt version 1.5, it would disable the feature for crypt
> version 2.2.

Yes, intention was just simple version check. Anyway, in most cases
code tries use feature, and only if it fails, it reports error
about missing support (this should prevent issues on some systems
with backported patches without module version changes).

Anyway, patch applied, thanks!

Milan


More information about the dm-crypt mailing list