[dm-crypt] Truecrypt and cryptdisks_start: failing with CRYPTTAB_OPTION_tcrypt-system: bad variable name

Claudio Moretti flyingstar16 at gmail.com
Wed Sep 11 02:00:45 CEST 2013


Hello everyone,

I have recently (aka today) encrypted my Windows system partition with
Truecrypt.
My system is booting fine (both Windows and Debian sid), but I have the
necessity of mounting the Windows partition when booting Debian (all my
files are there).

I found out that with a simple entry in /etc/crypttab this should be easily
done, but when I tried it, I got the following error:

[....] Starting crypto disk.../usr/sbin/cryptdisks_start: 1: export:
> CRYPTTAB_OPTION_tcrypt-system: bad variable name
>

I thought it was a bad-something happening with the Debian version of
cryptsetup (2:1.6.1-1), so I downloaded and compiled the 1.7.0-git version
and tried to use it. The same error occurs

root at Chuck:/home/claudio# /usr/sbin/cryptdisks_start truecrypt
> [....] Starting crypto disk.../usr/sbin/cryptdisks_start: 1: export:
> CRYPTTAB_OPTION_tcrypt-system: bad variable name
>

in an online version of the crypttab manpage[1] I can see the tcrypt and
tcrypt-system options, and how to use them; in my manpage (cryptsetup
2:1.6.1-1 2013-06-28 CRYPTTAB(5) ) there is no such thing.

I know that this is not the 1.7.0-git manpage, but (AFAIK) the tcrypt and
tcrypt-system options should be there and, nevertheless, 1.7.0-git does not
work.

I don't know how to solve this. I can't reboot rigth now, so I don't know
if the "workaround" I'm trying ('cat passwordfile | /usr/sbin/cryptsetup
--tcrypt-system tcryptOpen /dev/sda1 truecrypt' and 'mount -a' in
/etc/rc.local) works, but I'd prefer to use the 'built-in' function.

Any suggestions?

Thanks,

Claudio

[1] http://www.freedesktop.org/software/systemd/man/crypttab.html
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.saout.de/pipermail/dm-crypt/attachments/20130911/efc9bd9a/attachment.html>


More information about the dm-crypt mailing list