[dm-crypt] Can't access a LUKS encrypted partition

jeff.esquivel at gmail.com jeff.esquivel at gmail.com
Mon Aug 11 17:29:25 CEST 2014


Hi Arno,


On Mon, Aug 11, 2014 at 4:07 AM, Arno Wagner <arno at wagner.name> wrote:

> Most likely scenario: Something else changed in the password-input
> chain. Do you have any non-ISO-7bit chars in your passphrase? These
> will change their binary value when going to Unicode. You
> mau also have characters switched because of a keyboard-layout
> issue.
>

Sorry, I forgot to add that to my first e-mail, my password is made up of
only non-ISO-7bit ASCII characters (as checked on this table:
http://en.wikipedia.org/wiki/ASCII#ASCII_printable_code_chart) and since I
installed this OS (which was about a couple weeks before getting the new
hard disk) I've only had two layouts on it: US and US International. Is
copy+paste the passphrase from a text editor a good way to avoid both of
these issues or would that fail too?

The FAQ has more info in item 1.2
>
> Also note that asking a question on a mailing-list without
> subscribing is a sure way to miss answers and generally
> not a good idea. What you do is to subscribe, ask, and
> when things are cleared up, unsubscribe.
>

Ok, thanks for the information, I already subscribed. Sorry for not reading
the whole FAQ before, I just looked at the bits that seemed to be related
to my problem, but I'll make sure I read the whole thing today.


Thank you very much for your reply.

[...]


-- 
Jeffrey Esquivel S.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.saout.de/pipermail/dm-crypt/attachments/20140811/32741b30/attachment.html>


More information about the dm-crypt mailing list