[dm-crypt] Required kernel crypto interface not available

Milan Broz gmazyland at gmail.com
Thu May 15 19:35:17 CEST 2014


See cryptsetup man page

 TCRYPT  extension requires kernel userspace crypto API to be available (introduced in Linux kernel 2.6.38).  If you are configur‐
 ing kernel yourself,  enable  "User-space  interface  for  symmetric  key  cipher  algorithms"  in  "Cryptographic  API"  section
 (CRYPTO_USER_API_SKCIPHER .config option).

Milan

On 05/15/2014 04:58 AM, Franz wrote:
> Hello,
> 
> I am trying to follow this tutorial to mount truecrypt volumes with cryptsetup:
> http://forums.fedoraforum.org/showthread.php?p=1698596#post1698596
> But I'm getting this error:
> 
> "Required kernel crypto interface not available.
> Ensure you have algif_skcipher kernel module loaded."
> 
> So tried to load the kernel module, but got other error:
> 
> "[user at cryptsetup ~]$ sudo modprobe algif_skcipher
> modprobe: FATAL: Module algif_skcipher not found."
> 
> Is there a solution?
> 
> Best
> 
> Franz
> 
> 
> _______________________________________________
> dm-crypt mailing list
> dm-crypt at saout.de
> http://www.saout.de/mailman/listinfo/dm-crypt
> 


More information about the dm-crypt mailing list