[dm-crypt] configure

Almeida, Gabriel Gabriel.Almeida at harman.com
Mon Dec 7 15:38:14 CET 2015


sudo apt-get install libgcrypt20-dev made the trick.

Thanks


-----Original Message-----
From: Milan Broz [mailto:gmazyland at gmail.com] 
Sent: Montag, 7. Dezember 2015 15:32
To: Almeida, Gabriel; dm-crypt at saout.de
Subject: Re: [dm-crypt] configure


On 12/07/2015 03:12 PM, Almeida, Gabriel wrote:
> While trying to install cryptsetup and I get the following error... 
> Steps are done as follows:
> 
> 
> 
> $ git clone https://gitlab.com/cryptsetup/cryptsetup.git
> 
> $ git checkout v1_7_0
> 
> $ cd cryptsetup
> 
> 
> 
> At this point, instructions are asking to run ./configure, however 
> there is no such file inside.

Configure is distributed in tarballs, downloaded from https://www.kernel.org/pub/linux/utils/cryptsetup/

For git branch you need to run ./autogen.sh to generate it.

> So while running ./autogen.sh  I get the following error:
> 
> 
> 
> configure.ac:42: error: possibly undefined macro: AC_MSG_ERROR
> 
> If this token and others are legitimate, please use m4_pattern_allow.
> 
> See the Autoconf documentation.
> 
> configure.ac:156: error: possibly undefined macro: AM_PATH_LIBGCRYPT

You do not have all development packages installed.
(I guess pkgconfig or gcrypt devel here.)

I do not know your distro but better use tarball, run pregenerated configure and it will probably print more info.

Milan




More information about the dm-crypt mailing list