[dm-crypt] cryptsetup 1.6.2 hands on "waiting for zero"

Mrukant Popat mrukant at gmail.com
Mon May 4 20:56:50 CEST 2015


Dear All,

I am using cryptsetup 1.6.2 on a freescale imx6 processor. However when I
run "cryptsetup -v --debug luksFormat /dev/sdb1" it hangs. Below is the
output.

cryptsetup 1.6.2 processing "cryptsetup -v --debug luksFormat /dev/sda1"

# Running command luksFormat.

# Locking memory.

# Installing SIGINT/SIGTERM handler.

# Unblocking interruption on signal.


WARNING!

========

This will overwrite data on /dev/sda1 irrevocably.


Are you sure? (Type uppercase yes): YES

# Allocating crypt device /dev/sda1 context.

# Trying to open and read device /dev/sda1.

# Initialising device-mapper backend library.

# Timeout set to 0 miliseconds.

# Iteration time set to 1000 miliseconds.

# Interactive passphrase entry requested.

Enter passphrase:

Verify passphrase:

# Formatting device /dev/sda1 as type LUKS1.

# Crypto backend (OpenSSL 1.0.1l 15 Jan 2015) initialized.

# Topology: IO (512/0), offset = 0; Required alignment is 1048576 bytes.

# Generating LUKS header version 1 using hash sha1, aes, xts-plain64, MK 32
bytes

# Crypto backend (OpenSSL 1.0.1l 15 Jan 2015) initialized.

# KDF pbkdf2, hash sha1: 189959 iterations per second.

# Data offset 4096, UUID e03d45c9-65a9-488d-88f9-cf2619575f0c, digest
iterations 23125

# Updating LUKS header of size 1024 on device /dev/sda1

# Key length 32, device size 40960 sectors, header size 2050 sectors.

# Reading LUKS header of size 1024 from device /dev/sda1

# Key length 32, device size 40960 sectors, header size 2050 sectors.

# Adding new keyslot -1 using volume key.

# Calculating data for key slot 0

# Crypto backend (OpenSSL 1.0.1l 15 Jan 2015) initialized.

# KDF pbkdf2, hash sha1: 192752 iterations per second.

# Key slot 0 use 94117 password iterations.

# Using hash sha1 for AF in key slot 0, 4000 stripes

# Updating key slot 0 [0x1000] area.

# Calculated device size is 250 sectors (RW), offset 8.

# Detected kernel Linux 3.10.17-1.0.2_ga+g33597e3 armv7l.

# dm version   OF   [16384] (*1)

# dm versions   OF   [16384] (*1)

# Detected dm-crypt version 1.12.1, dm-ioctl version 4.24.0.

# Device-mapper backend running with UDEV support enabled.

# DM-UUID is Cbio: create slab <bio-1> at 1

RYPT-TEMP-temporary-cryptsetup-347

# Udev cookie 0xd4d2ea2 (semid 0) created

# Udev cookie 0xd4d2ea2 (semid 0) incremented to 1

# Udev cookie 0xd4d2ea2 (semid 0) incremented to 2

# Udev cookie 0xd4d2ea2 (semid 0) assigned to CREATE task(0) with flags
DISABLE_SUBSYSTEM_RULES DISABLE_DISK_RULES DISABLE_OTHER_RULES (0xe)

# dm create temporary-cryptsetup-347 CRYPT-TEMP-temporary-cryptsetup-347 OF
  [16384] (*1)

# dm reload temporary-cryptsetup-347  OFW    [16384] (*1)

# dm resume temporary-cryptsetup-347  OFW    [16384] (*1)

# temporary-cryptsetup-347: Stacking NODE_ADD (254,0) 0:0 0600 [verify_udev]

# temporary-cryptsetup-347: Stacking NODE_READ_AHEAD 256 (flags=1)

# Udev cookie 0xd4d2ea2 (semid 0) decremented to 1

# Udev cookie 0xd4d2ea2 (semid 0) waiting for zero





It hangs on "waiting for zero" . I see that this issue was discussed in
2013 ( http://www.saout.de/pipermail/dm-crypt/2013-November/003619.html
)but did not see the solution from author. Can somebody provide info if
this is already solved. Thanks


regards,
Mrukant Popat
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.saout.de/pipermail/dm-crypt/attachments/20150504/9b8d3987/attachment.html>


More information about the dm-crypt mailing list