[dm-crypt] [SOLVED] cryptsetup 1.6.2 hands on "waiting for zero"

Mrukant Popat mrukant at gmail.com
Tue May 5 01:54:04 CEST 2015


On Mon, May 4, 2015 at 12:56 PM, Mrukant Popat <mrukant at gmail.com> wrote:

>
>
>
>
> On Mon, May 4, 2015 at 12:40 PM, Milan Broz <gmazyland at gmail.com> wrote:
>
>> On 05/04/2015 09:29 PM, Mrukant Popat wrote:
>> > Hello Milan,
>> >
>> > Thanks for the quick answer. I cross-compiled all the tools using yocto
>> for iMX6 freescale.
>> > I read the information here  -->
>> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=585786   and
>> > here -->
>> http://comments.gmane.org/gmane.linux.debian.devel.bugs.general/719712
>> >
>> > and disabled udev  using /etc/init.d/udev stop.
>> >
>> > After disabling udev, it seems to work. Could you provide the udev
>> rules. Probably the reason is that I do not seem to have the udev rules.
>>
>> Udev rules are part of the device-mapper installation (part of lvm2
>> source code),
>> so check what version you are compiling and if udev is enabled, it should
>> install these rules.
>>
>> But AFAIK Debian still tries to reinvent the wheel and distributes own
>> modified lvm2/dm udev rules,
>> TBH I am not sure how it works now there.
>>
>> (On my Debian I have 55-dm.rules which completes that semaphore operation
>> your example is waiting for.)
>>
>> Milan
>>
>
> Hello Milan,
>
> Thanks for quick reply. Could you provide your 55-dm.rules for reference.
>
> Regards,
> Mrukant Popat
>
>
Hello Milan,

I was able to solve this using the 55-dm.rules file from my ubuntu distro
and making changes in path for dmsetup.
Thanks for your guidance.

Best Regards,
Mrukant Popat
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.saout.de/pipermail/dm-crypt/attachments/20150504/cefadb84/attachment.html>


More information about the dm-crypt mailing list