[dm-crypt] dmsetup or cryptsetup hangs in the initrd

Arno Wagner arno at wagner.name
Mon Oct 19 09:46:47 CEST 2015


On Mon, Oct 19, 2015 at 09:06:47 CEST, Milan Broz wrote:
> I guess you are missing dmsetup udev rules in initramfs
> or something like that. (Hint: just add --debug to cryptsetup and it will show where is is waiting.)
> 
> You should probably use systemd to activate crypt devices in RHEL7 anyway.
> 
> On 10/19/2015 08:21 AM, Arno Wagner wrote:
> >> Obviously, this has all been stripped down to make it as simple as
> >> possible. Sorry for the hard coding. If you want to test it, you need to
> >> provide a /dev/sdb1 partition that is at least 2G. If you comment out the
> >> `exit 0' in go.sh it will setup the partition for you.
> 
> Using hardcoded sdb1 is wrong, it will overwrite other disk if you e.g. forget
> USB drive plugged in. Use some hw id symlink.

Good point.

Arno
 
> >> Note that if 95dmcrypt.sh has either the dmsetup or the 2 cryptsetup lines
> >> commented in, it will hang the machine.
> 
> Run dracut shell, debug it by hand. 
> 
> Milan
> 
> _______________________________________________
> dm-crypt mailing list
> dm-crypt at saout.de
> http://www.saout.de/mailman/listinfo/dm-crypt

-- 
Arno Wagner,     Dr. sc. techn., Dipl. Inform.,    Email: arno at wagner.name
GnuPG: ID: CB5D9718  FP: 12D6 C03B 1B30 33BB 13CF  B774 E35C 5FA1 CB5D 9718
----
A good decision is based on knowledge and not on numbers. -- Plato

If it's in the news, don't worry about it.  The very definition of 
"news" is "something that hardly ever happens." -- Bruce Schneier


More information about the dm-crypt mailing list