[dm-crypt] Cryptsetup (>= 1.7.0) luksOpen/luksClose gets stuck after open/close

Milan Broz gmazyland at gmail.com
Thu Apr 7 21:24:15 CEST 2016


On 04/07/2016 08:47 PM, Guido Trentalancia wrote:
> Hello.
> 
> My first message contains the debug information (last part of the
> strace output).

No, it does not. Please post debug information and NOT strace as
I described in the first reply...

Just add --debug to cryptsetup command and you have it (without strace).
It contains a lot of info that is needed to debug almost all kind of cryptsetup problem.

You also missed request to post distro version here.
Do you compile cryptsetup yourself?

Anyway, I am almost sure you are missing the udev dmsetup udevcomplete
call in udev, this is very common error.

> If you need other information, please let me know. Obviously I cannot
> post gdb output as the program does not crash, it simply gets stuck.

Strace or gdb info is not needed if not requested, --debug log is usually
enough to see what is going on.

And did you try that "dmsetup udevcomplete_all" I already suggested?
(once it is "stuck", run from another terminal - is should finish that command)

> The two versions show a different behaviour (the working version reads
> SELinux configuration, the broken version opens /dev/urandom and gets
> stuck), so the code must have changed.

I do not know about any change there.
Running code depends on compilation parameters, some basic info how code
behaves is in the debug log I am still waiting for...


Milan


More information about the dm-crypt mailing list