[dm-crypt] Crypto-changes in some kernels

Milan Broz gmazyland at gmail.com
Sun Feb 21 08:13:44 CET 2016


On 02/20/2016 11:35 PM, Michael Strauss wrote:
> Hi all,
> 
> some (longterm stable) kernel got patches who seem to make them incompatible
> with cryptsetup. See for details:


> 
> http://thread.gmane.org/gmane.linux.kernel.stable/165742
> 
> I tried the git version of cryptsetup and that seem to fix it at least for
> 4.1.18. I noticed no problems so far.
> 
> A new tarball release would be a good idea I think.

They have release proper stable kernel with backported compatible patches
(it is kernel that changed API).

I spent a lot of time testing when this happened mainline (there is link
to discussion somewhere in the thread)...

Yes, it is "fixed" (changed so it works even with new kernel API changes)
in cryptsetup git and will be part of 1.7.1 release.
But I will not hurry with releasing something now just because stable kernel
maintainers are backporting things without any testing.
(Anyway, 1.7.1 will be released this week.)

Milan


More information about the dm-crypt mailing list