[dm-crypt] luksFormat still spinning/hanging with large array on kernel 4.6.2

Milan Broz gmazyland at gmail.com
Tue Jun 28 08:39:23 CEST 2016


Hi,

thanks for the info.

On 06/28/2016 05:01 AM, Charles Cazabon wrote:
> I've since moved the array over to another machine, also running Wheezy with
> the mainline 4.6.2 kernel.  cryptsetup luksFormat behaves the same there,
> spinning forever and taking one full CPU.
> 
> So is this a known or new incompatibility between cryptsetup and the newer
> kernel?  Or some other known issue?

Not (yet). It is perhaps some recent incompatibility but we have to reproduce and
track to proper component.
 
> Basically I'm wondering what I should be doing to get this working.  It *used*
> to work, given that I have another identical array running on this particular
> machine, and I did the cryptsetup luksFormat on it some six months ago with no
> issues.  The only changes between then and now are that the kernel and other
> system packages have been updated since.
> 
> Anyone have any advice for what to try here?  I'm willing to help compile with
> debugging patches or whatever if that would help track down where the problem
> lies.

That would be great. Please if you can compile cryptsetup from the branch "bench" with
added print inside PBKDF2 benchmark (https://gitlab.com/cryptsetup/cryptsetup/tree/bench)

and run the command again with --debug switch and send me the output.

I need to verify that it is the same problem (if it is, then getrusage() call
return all zeroed values).

Thanks,
Milan


More information about the dm-crypt mailing list