[dm-crypt] Missing keyslot or broken header or still some hope?

zero.tonin at web.de zero.tonin at web.de
Sun Nov 6 08:26:50 CET 2016


Good morning all, good morning Sven,

thank you very much for your message and insight and also for confirming parts of my understanding of the situation.

Now, getting back to my drive, I have to make the most embarrassing confession - for the last three days I actually tried to unlock the drive with my user account password and, in contrast to my initial words (which I eat now), _not_ with  the drive password. I have not the lsightest idea why, apart from the two (password and passphrase) being in use both for the same amount of time, which is roughly 5 years or so. 

The luks header and keyslot are not only intact, they are fully working and I can decrypt the drive no problem. Turns out it was, indeed, a "layer 8 problem". 

I am, while relieved I can recover the data, add a second keyslot and rsync the drive immediately, sincerely sorry for having used (some may say wasted) this list's and some individual's time,, but thanks again for all your help.

On the positive side, this forced me to learn a bit more about luks and what it actually does (instead of just using it) and also was an opportunity to lear to never again claim I am "100% certain about the password"…


Thanks again, all, and a great Sunday to everyone,
Mark

(I will take the liberty to remain on this list for future interesting topics)


More information about the dm-crypt mailing list