[dm-crypt] Veritysetup

Ondrej Kozina okozina at redhat.com
Wed Oct 25 11:24:26 CEST 2017


On 10/25/2017 11:12 AM, Viacheslav Salnikov wrote:
> Hello,
> 
> If veritysetup (and all cryptsetup) depends on libcryptsetup therefore 
> it won't work. Did I understand you correctly?

You may drop (not install) cryptsetup binary but you have to build and 
install libcryptsetup to have a working veritysetup. Yes.

> 
> Another question is, do I really need lvm2 package? Is it crucial for 
> cryptsetup?

Cryptsetup doesn't require lvm2 package. Also it doesn't depend on any 
lvm2 metadata. But libcryptsetup does depend on libdevmapper, low level 
library for setting up kernel device-mapper devices (dm-crypt, 
dm-verity, ...). Usually libdevmapper is standalone library but 
sometimes it's distributed together with lvm2 package. Depends what 
distribution you use.

O.


More information about the dm-crypt mailing list