[dm-crypt] Poor performane (idle cpu) [SOLVED; problem with "pv"]

M Thomas Frederiksen mahasamoot at gmail.com
Tue Feb 9 17:16:14 CET 2010

Hi Folks,

I have four disks.  I installed kubuntu 9.10 alt, using /dev/sda, /dev/sdb,
and /dev/sdc.  I had long used /dev/sdd1 (single partition for the whole
disk) as luks.  I kept all my backups on that disk, and didn't touch it at
all during the instillation.  The installation program said that /dev/sdd1
was LVM, which I thot was odd, however I didn't use or set up LVM at all on
any of the disks (hence didn't go into the settup LVM part of the install

Post install when I run cryptsetup:

thomas at Aristotle:~$ sudo cryptsetup luksOpen /dev/sdd1 backup_crypt
Enter LUKS passphrase:
Command failed: /dev/sdd1 is not a LUKS partition
thomas at Aristotle:~$ sudo cryptsetup luksDump /dev/sdd1
Command failed: /dev/sdd1 is not a LUKS partition
thomas at Aristotle:~$ shoot me now
shoot: command not found

There are two things I can think of:

   1. The install program wrote out a new partition table, changing the
   partition type flag.
   2. The /dev/sdXs were named differently, and I've scribbled all over what
   was /dev/sdd1.

 In the first case I think I have hope, in the second... If one is true what
steps should I take?


Samuel Goldwyn<http://www.brainyquote.com/quotes/authors/s/samuel_goldwyn.html>
- "I'm willing to admit that I may not always be right, but I am never
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.saout.de/pipermail/dm-crypt/attachments/20100209/0a29eb5e/attachment.html>

More information about the dm-crypt mailing list