[dm-crypt] Help! Command failed: /dev/sdd1 is not a LUKS partition

M Thomas Frederiksen mahasamoot at gmail.com
Wed Feb 10 18:00:39 CET 2010


Hi Folks,

I have four disks.  I installed kubuntu 9.10 alt amd64, using /dev/sda,
/dev/sdb, and /dev/sdc.  I had long used /dev/sdd1 (single partition for the
whole disk) as luks.  I kept all my backups on that disk, and didn't touch
it at all during the instillation.  The installation program said that
/dev/sdd1 was LVM, which I thot was odd, however I've used LVM in the past,
so that partition was likely still marked LVM when I started using it as
straight luks.  I didn't use or set up LVM at all on any of the disks (hence
didn't go into the settup LVM part of the install program).

Post install when I run cryptsetup:

thomas at Aristotle:~$ sudo cryptsetup luksOpen /dev/sdd1 backup_crypt
Enter LUKS passphrase:
Command failed: /dev/sdd1 is not a LUKS partition
thomas at Aristotle:~$ sudo cryptsetup luksDump /dev/sdd1
Command failed: /dev/sdd1 is not a LUKS partition
thomas at Aristotle:~$ shoot me now
shoot: command not found

There are three things I can think of:

   1. The install program wrote out a new partition table, changing the
   partition type flag.
   2. The /dev/sdXs were named differently, and I've scribbled all over what
   was /dev/sdd1.
   3. Mandriva was unaffected by the problem, but Kubuntu is.

In the first case I think I have hope, what steps should I take?  In the
second case, I think I'm SOL.  I tried using the Mandriva Live CD, and got
the same result, so the second & third cases are ruled out.

===========
I have another weird, lessor problem:

At boot time, my new luks partition /dev/sda3, says "command failed, bad key
or options" for all three tries then boots (because it is opened and just
doesn't know it).  I tested this by not giving it the passphrase, in which
case it won't boot, but if I type the passphrase right the first time, and
blow off the other 2 tries, it boots.  I thot this might be a btrfs problem,
so post boot, I formatted an empty luks partition as btrfs, and tried
unlocking it.  No problem.  To get root btrfs, I followed the instructions
here: http://ubuntuforums.org/showthread.php?t=1389279

============
Last issue:

I've got more drives to add to btrfs, but how will it know it needs to
unlock the other drives to open the root partition? It's only unlocking
/dev/sda3 during boot, because /dev/sdb2 and /dev/sdc2 aren't being used
(even tho, I've got them in the crypttab). From the fstab

/dev/mapper/sda3_crypt / btrfs error=remount-ro,compress 0 1

it looks like it just needs the one. Also, they all have the same
passphrase, so I'd like to unlock them all at once... which mandriva did,
but kubuntu doesn't. Ideas?

-- 
Cheers,
~Thomas


Samuel Goldwyn<http://www.brainyquote.com/quotes/authors/s/samuel_goldwyn.html>
- "I'm willing to admit that I may not always be right, but I am never
wrong."
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.saout.de/pipermail/dm-crypt/attachments/20100210/86666a41/attachment.html>


More information about the dm-crypt mailing list