[dm-crypt] _unformatted in /dev/mapper/

Jonas Meurer jonas at freesources.org
Wed Jul 21 00:28:08 CEST 2010


Hey Aarto,

On 21/07/2010 Aarto Matti wrote:
> On Fri, Jul 16, 2010 at 3:10 AM, Aarto Matti <aarto.matti at gmail.com> wrote:
> 
> > Hello,
> >
> > I'm new here. I followed this tutorial
> > https://www.antagonism.org/privacy/encrypted-swap-linux.shtml and after I
> > boot I find extra _unformatted node in /dev/mapper/
> >
> > $ ls /dev/mapper/
> > control  swap swap_unformatted
> >
> > But if I run cryptsetup manually then no problem. Is it a bug or I do
> > something wrong? I googled it and didn't find any useful answer.
> >
> >
> Please correct me if I write to the wrong list, but that "_unformatted"
> thing really bothers me. I repeated several times with clean installation
> and got the same result. I use cryptsetup 1.1.0-rc2 and Ubuntu 10.04.

seems like this is a distribution specific bug. please see the ubuntu
bug tracking system, in particular take a look at the following bugs:
https://bugs.launchpad.net/ubuntu/+source/cryptsetup/+bug/502665
https://bugs.launchpad.net/ubuntu/+source/udev/+bug/508848

at the end of the second buglog, the issue is identified as a filesystem
signatures issue. the device in question seems to contain more than one
filesystem signatures. what's the result of the following commands:

# blkid -p /dev/mapper/swap
# wipefs -n /dev/mapper/swap

please also post your /etc/crypttab. since the device in question
(/dev/mapper/swap) seems to be used as swap device, wiping the
filesystem signatures on it shouldn't be a problem at all.

greetings,
 jonas
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 490 bytes
Desc: Digital signature
URL: <http://www.saout.de/pipermail/dm-crypt/attachments/20100721/3324ef0a/attachment.asc>


More information about the dm-crypt mailing list