[dm-crypt] _unformatted in /dev/mapper/

Aarto Matti aarto.matti at gmail.com
Wed Jul 21 21:52:52 CEST 2010


Hello Jonas,

On Wed, Jul 21, 2010 at 1:28 AM, Jonas Meurer <jonas at freesources.org> wrote:

>  seems like this is a distribution specific bug. please see the ubuntu
> bug tracking system, in particular take a look at the following bugs:
> https://bugs.launchpad.net/ubuntu/+source/cryptsetup/+bug/502665
> https://bugs.launchpad.net/ubuntu/+source/udev/+bug/508848
>
> at the end of the second buglog, the issue is identified as a filesystem
> signatures issue. the device in question seems to contain more than one
> filesystem signatures. what's the result of the following commands:
>
> # blkid -p /dev/mapper/swap
> # wipefs -n /dev/mapper/swap
>

Thanks for replying. The reporter had the same issue but seems it was caused
a bit differently, I don't have problems with signatures:

# blkid -p /dev/mapper/swap
/dev/mapper/swap: UUID="72da72f5-cd68-4252-ae58-9824b6683b20" VERSION="2"
TYPE="swap" USAGE="other"

# wipefs -n /dev/mapper/swap
offset               type
----------------------------------------------------------------
0xff6                swap   [other]
                     UUID:  72da72f5-cd68-4252-ae58-9824b6683b20

please also post your /etc/crypttab. since the device in question
> (/dev/mapper/swap) seems to be used as swap device, wiping the
> filesystem signatures on it shouldn't be a problem at all.
>

I have also tried other names, other than "swap", originally I used
"cryptoswap" as in the tutorial. Only then after I got some understanding
how it works I started to play with other names. But anyways,

/etc/crypttab:
 # <target name>    <source device>        <key file>    <options>
swap /dev/sda5 /dev/urandom
swap,cipher=aes-cbc-essiv:sha256,size=256,hash=sha256

/etc/fstab:
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=c01898b3-ec14-46b8-b129-5f13020bbdf6 /               ext4
errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
#/dev/sda5 none                 swap    sw              0       0
/dev/mapper/swap swap           swap    sw              0       0

--
Aarto
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.saout.de/pipermail/dm-crypt/attachments/20100721/0398ab01/attachment.html>


More information about the dm-crypt mailing list