[dm-crypt] My sequence of failure

machiner machiner at gmail.com
Sat Sep 4 14:11:29 CEST 2010


I reinstalled Debian a few weeks ago (dselect).  Last night I plugged my backup drive
in that I may resume normal backup procedures.  In a fit of stupid, I probably lost
my backup data forever.  Here is what I did.

Upon plugging the USB drive in I was greeted with a small dialog box that informed
me that /dev/sdb1 was encrypted and that I needed to input the password.  I did.


1 - # cryptsetup luksOpen /dev/sdb1 backup
2 - # mkfs.ext3 /dev/mapper/backup
3 - # mount /dev/mapper/backup /mnt/backup

Of course when I went to look upon my existing backups the drive was empty.  Of
course I overwrote the file system.  I did a number of things wrong....Large
quantities of alcohol were involved.

I tried testdisk with varying failures.  Stuff was seen, ish, but it ended there. P
to list files aborted testdisk.  Ran it looking for Intel partitions and also for

I see 3 instances of the drive when I run testdisk with no arguments.

Disk /dev/sdb - 320 GB / 298 GiB - WDC WD32 00BEVT-60ZCT0
Disk /dev/mapper/backup - 320 GB / 298 GiB
Disk /dev/dm-0 - 320 GB / 298 GiB

I looked around the mailing list and saw things like headers and salts and figured I
was doomed.  But I'm here anyway asking if there's anything I can do to attempt to
retrieve my existing backups.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://www.saout.de/pipermail/dm-crypt/attachments/20100904/02094a1e/attachment.asc>

More information about the dm-crypt mailing list