[dm-crypt] Replacing cryptoloop with dm-crypt in Debian with twofish and offset

Admin bonnefoy.eu site at bonnefoy.eu
Wed Apr 13 12:04:07 CEST 2011


I had offset with cryptoloop using twofish. But i'm unable to mount it with
I used to mount this like that:

losetup -e twofish -o 2560 /dev/loop0 /dev/sdb1 => enter passphrase
mount -t ext3 /dev/loop0 /home/

I tried with your command :
cryptsetup create -c twofish -o 2560 testAB /dev/sdb1
and then :
mount /dev/mapper/testAB test/

i tried with --skip option as well without success

But it's not working (wong FS type).

As I change my kernel to 2.6.32 recently, cryptoloop is not available any
more natively. I recompiled the module and I'm still able to mount file
system as before.

Do you see something wrong?

Thanks for help

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.saout.de/pipermail/dm-crypt/attachments/20110413/a691741e/attachment.html>

More information about the dm-crypt mailing list