[dm-crypt] Replacing cryptoloop with dm-crypt in Debian with twofish and offset

Arno Wagner arno at wagner.name
Wed Apr 13 15:21:05 CEST 2011


one thing that I immediately see is that losetup
specifies the offset in bytes, while cryptsetup uses
sectors (of 512 bytes).

Maybe try 

  cryptsetup create -c twofish -o 5 testAB /dev/sdb1


On Wed, Apr 13, 2011 at 12:04:07PM +0200, Admin bonnefoy.eu wrote:
> Hello,
> I had offset with cryptoloop using twofish. But i'm unable to mount it with
> cryptosetup.
> I used to mount this like that:
> losetup -e twofish -o 2560 /dev/loop0 /dev/sdb1 => enter passphrase
> mount -t ext3 /dev/loop0 /home/
> I tried with your command :
> cryptsetup create -c twofish -o 2560 testAB /dev/sdb1
> and then :
> mount /dev/mapper/testAB test/
> i tried with --skip option as well without success
> But it's not working (wong FS type).
> As I change my kernel to 2.6.32 recently, cryptoloop is not available any
> more natively. I recompiled the module and I'm still able to mount file
> system as before.
> Do you see something wrong?
> Thanks for help
> Antoine

> _______________________________________________
> dm-crypt mailing list
> dm-crypt at saout.de
> http://www.saout.de/mailman/listinfo/dm-crypt

Arno Wagner, Dr. sc. techn., Dipl. Inform., CISSP -- Email: arno at wagner.name 
GnuPG:  ID: 1E25338F  FP: 0C30 5782 9D93 F785 E79C  0296 797F 6B50 1E25 338F
Cuddly UI's are the manifestation of wishful thinking. -- Dylan Evans

If it's in the news, don't worry about it.  The very definition of 
"news" is "something that hardly ever happens." -- Bruce Schneier 

More information about the dm-crypt mailing list