[dm-crypt] recovering forgotten passwords for 2 LVs

ken gebser at mousecar.com
Tue Aug 23 02:23:59 CEST 2011

On 08/22/2011 06:53 PM Milan Broz wrote:
> On 08/23/2011 12:33 AM, ken wrote:
>> On the other hand, if I do a "vgdisplay /dev/sda5", I get a series of
>> lines saying "Input/output error" along with the locations of those
>> errors, ending with the statement 'Volume group "sda5" not found'.
>> I'd think that if vgdisplay can't locate the volume group, then vgchange
> No. vgdisplay does not take physical path as argument, this
> command must fail. (but io errors indicate something more
> serious - what exactly it says?)

You're right... vgdisplay takes the VG name as its arg.

> Whatever, seems you are doing several mistakes, lets try this:
> /dev/sda5 is LUKS device for sure, you have to first activate:
> 1) cryptsetup luksOpen /dev/sda5 sda5_crypt

# cryptsetup luksOpen /dev/sda5 sda5_crypt
Enter LUKS passphrase for /dev/sda5:
Enter LUKS passphrase for /dev/sda5:
Enter LUKS passphrase for /dev/sda5:
Command failed: No key available with this passphrase.

I tried three different passphrases.  None worked.  This is the original
problem.  If I knew the passphrase-- even just for the data partition--
I'd be done... the whole problem would be solved for me.

Since I don't know the passphrase for the command above, I can't do any
of the rest of these commands.

> does it work and device is properly unlocked? If so, then
> 2) please paste output of: "blkid /dev/mapper/sda5_crypt"
> I guess it will be LVM PV. If so then run
> 3) vgscan ; vgchange -a y
> 4) paste here output of "blkid /dev/mapper/*"
> Maybe you can add also "blkid /dev/sd*" so we can be sure what's
> type of partitions you have there - the grub entry you mentioned
> does not match the device on /dev/sda5.
> (I would say paste here output of "lsblk -f" but this command is not
> yet in CentOS5.)
> Thanks,
> Milan

Thanks, Milan.

More information about the dm-crypt mailing list