[dm-crypt] luksFormat hangs

Martin Hicks mort at bork.org
Tue Jun 28 21:56:48 CEST 2011


I'm trying to create a luks device on an embedded platform running
kernel 2.6.37 and cryptsetup 1.3.1.  I'm sure I've done this before,
but when I tried today I end up with a hang that consumes all CPU and
based on a combination of --debug and strace I think it is in the
PBKDF2_perforance_check function.

/conf/root # cryptsetup --debug -q luksFormat /dev/dtdb1
# cryptsetup 1.3.1 processing "cryptsetup --debug -q luksFormat /dev/dtdb1"
# Running command luksFormat.
# Locking memory.
# Allocating crypt device /dev/dtdb1 context.
# Trying to open and read device /dev/dtdb1.
# Initialising device-mapper backend, UDEV is disabled.
# Detected dm-crypt version 1.7.0, dm-ioctl version 4.18.0.
# Password verification enabled.
# Timeout set to 0 miliseconds.
# Iteration time set to 1000 miliseconds.
# Interactive passphrase entry requested.
Enter LUKS passphrase:
# Formatting device /dev/dtdb1 as type LUKS1.
# OpenSSL crypto backend initialized.
# Topology: IO (512/0), offset = 0; Required alignment is 1048576 bytes.
# Generating LUKS header version 1 using hash sha1, aes,
cbc-essiv:sha256, MK 32 bytes

The platform is ppc mpc8379-rdb.  I've tried on the platform with the
hardware encryption engine and on one without, although I don't think
I'm getting to the stage where the kernel really cares about that.

Any ideas?

Martin Hicks P.Eng.      |         mort at bork.org
Bork Consulting Inc.     |   +1 (613) 266-2296

More information about the dm-crypt mailing list