[dm-crypt] luksFormat hangs

Milan Broz mbroz at redhat.com
Tue Jun 28 22:14:37 CEST 2011


On 06/28/2011 09:56 PM, Martin Hicks wrote:
> I'm trying to create a luks device on an embedded platform running
> kernel 2.6.37 and cryptsetup 1.3.1.  I'm sure I've done this before,
> but when I tried today I end up with a hang that consumes all CPU and
> based on a combination of --debug and strace I think it is in the
> PBKDF2_perforance_check function.

well, I would really like to know what went wrong there.

Is it something new in 1.3.1? (It shouldn't, there was no changes).

Which compile option are you using (configure options)?
(mainly which crypto backend - libgcrypt?)
Anything special with libc, environment or so?

> /conf/root # cryptsetup --debug -q luksFormat /dev/dtdb1

Can you try to add "-i 1" - is is still looping?

> The platform is ppc mpc8379-rdb.  I've tried on the platform with the
> hardware encryption engine and on one without, although I don't think
> I'm getting to the stage where the kernel really cares about that.

If it is loops in PBKDF2 perf. check, I do not think the problem is in hw
acceleration (depends if userspace lib uses hw acceleration but I think
it is  not, hw acceleration is used probably in kernel only.)

I guess "cryptsetup create" command work without problem, right?


More information about the dm-crypt mailing list