[dm-crypt] please HELP - can't acces encrypted LVM after linux reinstallation.

Aleksander Swirski aleksanderswirski at gmail.com
Fri Oct 28 17:23:07 CEST 2011

Dear friends,
please forgive me my ignorance , if anything is unclear, I will explain
further and will post any info needed.
for quite some time (3 yrs) I had LVM with all partitions of my debian
(root, usr, home, swap) except boot set up inside LUKS encrypted disk. With
time I moved from debian stable to testing (by virtue of dist-upgrade). At
some point I got little but annoying problems with my system - automount
wouldn't work, burner wouldn't burn DVDs, and also system-tools started
failing giving "unrecognized error" on authorization attempt. Because my
recent backups unfortunately already got some issues which I didn't discover
early I would have to travel back in time quite far to get my system stable
again. Instead I decided to set it up anew.

Just didn't want to damage data on my /home partition (within encrypted
LVM), the rest was to be wiped out. I managed to do this feat once in the
past, and got the feeling I know how it goes. But this time I made it the
wrong way obviously. Everything seemed to be fine. When the installer was
running before starting the manual partitioning I executed shell to do
cryptsetup luksOpen and vgchange -ay on my encrypted lvm, so that the
partitions inside were visible to the installer and ready for new system.
This worked. I mounted /home from within this LVM, as a mental marker not to
overwrite it.

In partitioner I marked /usr and / and swap from within LVM to be formated &
filled with new system data. I didn't of course run erasure with random
data. I only marked /home partition to be used as /home but checked it to
keep the data and to leave ext3 intact. Then comes the mistake. I marked the
encrypted drive, to be used, well as encrypted drive under new system.
Installer asked me to provide the pass-phrase (2 times to verify) and I gave
same pass-phrase as was set on this device before. There was no warning :(
the installation went fine. Just before first restart on installation
completion, I executed shell again to check that /home and data was there
and in fact everything was in it's place. I was happy, but then I restarted
the system and ... It couldn't find LVM and wouldn't start. I ran knoppix to
check what has happened. I could open encrypted device giving the usual
passpharse, but LVM inside was gone. instead of /dev/mapper/olek-root
/dev/mapper/olek-usr /dev/mapper/olek-home /dev/mapper/olek-swap inside
/dev/mapper dir I got only /dev/mapper/olek and /dev/mapper/control.
vgchange -ay olek returned : volume group olek not found

I now realize what might have happened. As I explained I set up same
passphrase again on this crypt disk when installing new system. But I
suspect, encryption key underneath could be changed and LVM is now
scrambled? I didn't back up many important files, because my other drive
failed not long time ago and didn't get new one yet due to cash shortage. Is
there any hope? PLEASE if anybody can help me. Is it possible to regain
acces to this LVM? I know it is there, it wasn't overwritten and I can do
luksOpen, but I can't see it inside and only now I understand how much I
need this data back ...
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.saout.de/pipermail/dm-crypt/attachments/20111029/aabc5947/attachment.html>

More information about the dm-crypt mailing list