[dm-crypt] Query on validating cryptsetup

Abhishek Tiwari abhis.tiwari at gmail.com
Wed Oct 3 19:28:54 CEST 2012


I am trying to use cryptsetup for an SD card. I create the crypto mapper
device and write a file to it. For the purpose of validation, I am using a
fixed key "11111111" as passphrase. Then I tried to see the contents of
this SD card using a reader and WinHex. Unfortunately these contents do not
match with an encrypted copy of same file that was encrypted using this
online DES encryption tool:
I specified algorithm as DES and mode as CBC.

When creating crypto device, my command is:
cryptsetup -c des-cbc-plain --key-size=64 --key-file=keyfile create sdcard0

Here, keyfile contains "11111111".

I tried with some other tools as well but could not get the exact same
output. Is there anything else that I need to look at?

Also, is there any other way I can verify my usage of keys and encryption
done using cryptsetup?

Please see if you can help. Thanks.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.saout.de/pipermail/dm-crypt/attachments/20121003/44ceacd9/attachment.html>

More information about the dm-crypt mailing list