[dm-crypt] Migrating from loop AES to dm-crypt

Nick Battle nick.battle at gmail.com
Fri Sep 14 22:08:50 CEST 2012

On 14/09/12 19:00, Arno Wagner wrote:
> I also have no idea what you need, but loop AES has no metadata,
> i.e. the correct options need to be given every time. That
> means your openSUSE 12.1 gave them, either because it was the
> defaults used there, or because they were encoded somewhwere
> (crypttab?)

All I think I have to go on is the openSUSE mount(1) options that worked (-o

> In the first case an OpenSUSE 12.1 life CD should help.
> In the second case you need to find the parameters, for
> example in a backup of the old system.

I should presumably be able to mount using an old live CD, but if that's using
losetup (albeit via mount), I'm not sure how to find the actual parameters.

> If you get the container mapped with the old openSUSE,
>    dmsetup table --target crypt --showkey /dev/mapper/<device>
> should give cipher, mode and offsets.

Will that work even for a "plain" losetup with a cipher. That looks like a
dm-crypt tool?

> If you figure it out, can you tell me which parameters worked
> for cryptsetup, so I can add them in Secrion 7 of the FAQ? Thanks!

Yes, absolutely!


More information about the dm-crypt mailing list