[dm-crypt] Encrypt all partitions with dm-crypt

Stayvoid stayvoid at gmail.com
Tue Sep 25 05:12:08 CEST 2012


Let's forget about Lemote specific issues.

For some reason I can't mount my partition when I'm using a USB stick.

Here is what I did:

1. Booted from a USB stick;

2. Created a mapping:

   # cryptsetup -c aes-xts-plain -s 512 -y create main /dev/sda3

3. Created a filesystem:

   # mkfs.ext3 /dev/mapper/main

4. Mounted it:

   # mount -t ext3 /dev/mapper/main /media/parabola

   It worked fine.

5. Unmounted it:

   # umount /media/parabola

6. Detached the partition:

   # cryptsetup remove main

Then I tried to use the same partition:

# cryptsetup create main /dev/sda3
# mount -t ext3 /dev/mapper/main /media/parabola

mount failed.

"If the password is not correct, the mount command will fail. In this
case simply remove the map sdc1 (cryptsetup remove sdc1) and create it
again." [1]

I'm sure that I was using the right password.

What is the problem?

[1] http://sleepyhead.de/howto/?href=cryptpart


More information about the dm-crypt mailing list