[dm-crypt] 1.6.2 - waiting for zero, luksFormat hung

shmick at riseup.net shmick at riseup.net
Thu Nov 21 15:55:26 CET 2013

Milan Broz:
> On 11/20/2013 05:44 PM, shmick at riseup.net wrote:
>> ./configure --with-crypto_backend=openssl --enable-dev-random
>> cryptsetup benchmark
>> # Tests are approximate using memory only (no storage IO).
>> cryptsetup: relocation error: cryptsetup: symbol crypt_benchmark_kdf,
>> version CRYPTSETUP_1.0 not defined in file libcryptsetup.so.4 with link
>> time reference
> You are compiling own version, but code apparently tries to load old
> libryptsetup library from system.
> (And it seems I did lib versioning wrong here ...)

i tried compiling with libgcrypt 1.5.3 but the same errors occur

> Either try to run src/cryptsetup (libtool wrapper should provide proper paths)
> or override library path using LD_LIBRARY_PATH.
> (it should point to src/lib/.libs or so)

same problem
./configure --with-libgcrypt-prefix=/usr/local LDFLAGS=-L/usr/local/lib
(this is where libgcrypt is)

> (Or if you installed compiled version, be sure it overwrites old libcryptsetup.)

ive also then tried with my distro default cryptsetup 1.4.1 but the same
errors again in xts mode with AES or TWOFISH

any ideas ???

> Milan

More information about the dm-crypt mailing list