[dm-crypt] Some problems with veritysetup command

Milan Broz gmazyland at gmail.com
Thu Nov 21 18:56:20 CET 2013


On 11/21/2013 04:12 PM, Mikulas Patocka wrote:
>> If I run the following command
>>     #veritysetup format /dev/sdb /dev/sdc

this should work. But I think you have some problem with installation
of veritysetup & libcryptsetup.

What distro you are using, Ubuntu? Why are you using alien to install package?
(Using Fedora package on other distros is not a good idea.)

Veritysetup is already packaged in unstable/testing Debian
(maybe Ubuntu has own build as well)

# dpkg -S /sbin/veritysetup
cryptsetup-bin: /sbin/veritysetup

# apt-cache policy cryptsetup-bin
  Installed: 2:1.6.1-1
  Candidate: 2:1.6.1-1
  Version table:
 *** 2:1.6.1-1 0
        500 http://ftp.de.debian.org/debian/ testing/main amd64 Packages
        990 http://ftp.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status

Please try to use this version (it works for me, just tried it on Debian unstable).
Do not use rpm packages, it can have serious incopmabilities (at lease for device-mapper


More information about the dm-crypt mailing list