[dm-crypt] External hard drives encrypted with cryptsetup suddenly stop working while internal disk is fine

cdupree chuck at chuckdupree.com
Sun Sep 8 02:27:16 CEST 2013

I apologize if this is an inappropriate place to post this question but I'm
in a difficult spot and am hoping to find help or referrals to other sources.

I've only recently encrypted my internal hard drive and my two externals,
though not yet my netbook's.  For the externals I used cryptsetup 1.4.3, the
current version in the repositories (I'm on Kubuntu Raring).  Things were
working fine for a month or so.  Then two days ago I had to reboot after
some updates and KDEwallet gave me some error message I couldn't note down
in time.  I'd been meaning to switch the last few passwords over to KeePassX
anyway, so I did that.  But from that time on I've had trouble mounting the
two external drives.  Right now I'm unable to read either of them.  Yet the
internal drive, which I encrypted when I installed Kubuntu & LVM initially,
has no problems.

When the trouble first appeared I tried plugging the external drives into
the netbook, which also has cryptsetup, though I've just noticed it seems to
be still at 1.4.1.  It claimed to be unable to mount the drives, but it let
me access them, not just read but even delete one.  So I breathed a sigh of
relief and moved them back to the desktop, but now I can't get to them from
either computer.

Can anyone help me figure this out?  I haven't tried any of the cryptsetup
commands because I don't know the software well enough to know what to look
for.  If there's a better place me to ask this question please feel free to
point me there so I won't take up your bandwidth unnecessarily.  Thanks!

- ced

More information about the dm-crypt mailing list