[dm-crypt] Truecrypt and cryptdisks_start: failing with CRYPTTAB_OPTION_tcrypt-system: bad variable name

Arno Wagner arno at wagner.name
Wed Sep 11 02:42:11 CEST 2013

On Wed, Sep 11, 2013 at 02:00:45AM +0200, Claudio Moretti wrote:
> Hello everyone,
> I have recently (aka today) encrypted my Windows system partition with
> Truecrypt.
> My system is booting fine (both Windows and Debian sid), but I have the
> necessity of mounting the Windows partition when booting Debian (all my
> files are there).
> I found out that with a simple entry in /etc/crypttab this should be easily
> done, but when I tried it, I got the following error:
> [....] Starting crypto disk.../usr/sbin/cryptdisks_start: 1: export:
> > CRYPTTAB_OPTION_tcrypt-system: bad variable name
> >
> I thought it was a bad-something happening with the Debian version of
> cryptsetup (2:1.6.1-1), so I downloaded and compiled the 1.7.0-git version
> and tried to use it. The same error occurs
> root at Chuck:/home/claudio# /usr/sbin/cryptdisks_start truecrypt
> > [....] Starting crypto disk.../usr/sbin/cryptdisks_start: 1: export:
> > CRYPTTAB_OPTION_tcrypt-system: bad variable name
> >
> in an online version of the crypttab manpage[1] I can see the tcrypt and
> tcrypt-system options, and how to use them; in my manpage (cryptsetup
> 2:1.6.1-1 2013-06-28 CRYPTTAB(5) ) there is no such thing.
> I know that this is not the 1.7.0-git manpage, but (AFAIK) the tcrypt and
> tcrypt-system options should be there and, nevertheless, 1.7.0-git does not
> work.

I suspect the problem is that sid uses systemd-44 while freedesktop has
version 206 as newest (44 being "stable" and "206" development?),
and the man-page for crypttab likely references the development
version. As that was made, cryptsetup could not yet (I think) 
handle tcrypt volumes.
> I don't know how to solve this. I can't reboot rigth now, so I don't know
> if the "workaround" I'm trying ('cat passwordfile | /usr/sbin/cryptsetup
> --tcrypt-system tcryptOpen /dev/sda1 truecrypt' and 'mount -a' in
> /etc/rc.local) works, but I'd prefer to use the 'built-in' function.

For 'built-in' I suspect you would need to get Debian to update
systemd. As it is a critical part of the system, there may be issues
preventing that at this time.
> Any suggestions?

Your workaround looks good to me. You could also make a proper
boot script, with the dependency-headers, it is not that hard.


> Thanks,
> Claudio
> [1] http://www.freedesktop.org/software/systemd/man/crypttab.html

> _______________________________________________
> dm-crypt mailing list
> dm-crypt at saout.de
> http://www.saout.de/mailman/listinfo/dm-crypt

Arno Wagner,     Dr. sc. techn., Dipl. Inform.,    Email: arno at wagner.name
GnuPG: ID: CB5D9718  FP: 12D6 C03B 1B30 33BB 13CF  B774 E35C 5FA1 CB5D 9718
There are two ways of constructing a software design: One way is to make it
so simple that there are obviously no deficiencies, and the other way is to
make it so complicated that there are no obvious deficiencies. The first
method is far more difficult.  --Tony Hoare

More information about the dm-crypt mailing list