[dm-crypt] Can't access a LUKS encrypted partition

jeff.esquivel at gmail.com jeff.esquivel at gmail.com
Mon Aug 11 17:16:49 CEST 2014

Hi Konstanin,

On Sun, Aug 10, 2014 at 11:37 PM, Konstantin Bläsi <ktrackfd at googlemail.com>


> Hi,
> make sure all required kernel modules are _loaded_ before using cryptsetup
> (a few bugs have been discovered lately depending on that condition).

I just tried after modprobe'ing dm-crypt, aes and sha256, the only error I
got was this:

$ sudo modprobe aes
modprobe: ERROR: could not insert 'padlock_aes': No such device

But lsmod shows that there is at least one aes module loaded (I think it is
a hardware accelerated version of AES):

$ lsmod | grep aes
aesni_intel           152648  5634
aes_x86_64             17131  1 aesni_intel
lrw                    13323  1 aesni_intel
glue_helper            14095  1 aesni_intel
ablk_helper            13597  1 aesni_intel
cryptd                 20531  2818

Another thing that may be important, I was following a guide (
when setting up LUKS and it recommended that I created the a modprobe alias
file in case of failure when loading the modules, so I did (I added alias
aes aes_generic to /etc/modprobe/aliases.conf), but it failed with a
different error:

$ sudo modprobe aes
modprobe: ERROR: ../libkmod/libkmod-module.c:809
kmod_module_insert_module() could not find module by name='aes_generic'
modprobe: ERROR: could not insert 'aes_generic': Function not implemented

So I removed that alias altogether (this was the day I was creating the
encrypted volume). I already tried to unlock the volume both ways (with
that alias present and without it) and neither way has worked.

> Did you try some live iso image like systemrescuecd?

I haven't tried this yet as I'm afraid that could make things worse (in
case there is some weird bug like the swap bug mentioned in my first
e-mail), but if you think it is worth trying, I'll do so.

> I found a case where the latest kbd package (responsible for the keyboard
> layout) broke the correct entry of the password:
> https://bbs.archlinux.org/viewtopic.php?id=169408

Ok, I'll take a look and see if that could apply here (but I'm not
optimistic as I already tried entering my password on Gedit and then
copy+paste it into cryptsetup's prompt).

>  Greetings ;)

Thank you very much for your reply.

Jeffrey Esquivel S.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.saout.de/pipermail/dm-crypt/attachments/20140811/289e56f0/attachment.html>

More information about the dm-crypt mailing list