[dm-crypt] Can't access a LUKS encrypted partition

jeff.esquivel at gmail.com jeff.esquivel at gmail.com
Mon Aug 11 21:07:37 CEST 2014

Hi Arno,

On Mon, Aug 11, 2014 at 11:45 AM, Arno Wagner <arno at wagner.name> wrote:

> On Mon, Aug 11, 2014 at 17:29:25 CEST, jeff.esquivel at gmail.com wrote:
> > Hi Arno,
> >
> >
> > On Mon, Aug 11, 2014 at 4:07 AM, Arno Wagner <arno at wagner.name> wrote:
> >
> > > Most likely scenario: Something else changed in the password-input
> > > chain. Do you have any non-ISO-7bit chars in your passphrase? These
> > > will change their binary value when going to Unicode. You
> > > mau also have characters switched because of a keyboard-layout
> > > issue.
> > >
> >
> > Sorry, I forgot to add that to my first e-mail, my password is made up of
> > only non-ISO-7bit ASCII characters (as checked on this table:
> > http://en.wikipedia.org/wiki/ASCII#ASCII_printable_code_chart) and
> since I
> > installed this OS (which was about a couple weeks before getting the new
> > hard disk) I've only had two layouts on it: US and US International. Is
> > copy+paste the passphrase from a text editor a good way to avoid both of
> > these issues or would that fail too?
> I think there is a misunderstanding here:
>    ISO-7bit = original 7 bit ASCII.
> Do you only have chars from the table you link? If so, you have only
> ISO-7bit chars. As the US-international layout has only ISO-7bit
> chars on it, inputting anything else would be pretty difficult with
> that layout.

Ok, I get it now, sorry, I thought only extended charsets used the ISO
abbreviation (such as ISO-8859-1, etc.), didn't know ASCII in itself was an
ISO standard. My passphrase uses only ISO-7bit characters (all of the
characters in my passphrase appear on the Wikipedia table I linked before).
I can also send you the password if it helps (I'm not using it for anything
important other than this).

As to text-editor: That has the same issues, except for the
> keyboard layout.

Ok, got it.

> (If you do not use any of the original ASCII/ISO-7bit chars,
> I would be curious how you enter them with an US keyboard.
> Windows-key remapped to compose?)

> I still suspect you switched locales at some point or there
> is a dropped line-ending or something like that. Did you
> use cryptsetup directly before and after it stopped working?
> Same shell? Tried to switch y and z? Some capitalization-error?

I did the formatting using cryptsetup directly on the command line, but all
of the successful unlocks where done using Ubuntu's window, something like
the one shown in this screenshot: http://www.imagebot.net/wally/1914 ,
after I couldn't unlock the partition with this method, I switched to
trying it on the command line directly (in case there was some Ubuntu/GTK
stuff that was getting in the way).

I have tried a lot of possible typos combinations (1536 to be exact, I
generated them with a tool that would generate all of the strings that
match a given regular expression and then thought about all the possible
typos I could make on this keyboard with this layout) using the crypt_dict
tool that came with the cryptsetup tarball.

Other information which may be important: I'm using cryptsetup 1.6.1 (and
compiled both crypt_dict and chk_luks_keyslots using that version's
tarball), also I'm using kernel 3.16.0-031600rc6-generic (because this new
machine has some quirks that are resolved only in the latest kernel

Another could-be important fact: I tried stracing cryptsetup and I don't
see my passphrase anywhere (on the FAQ said that it may be possible that
the passphrase could be seen on an strace, but I don't know if that would
be in ASCII or as the hex value of each character).

Thank you very much for all the help, I really appreciate it,

Jeffrey Esquivel S.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.saout.de/pipermail/dm-crypt/attachments/20140811/8f406458/attachment-0001.html>

More information about the dm-crypt mailing list