[dm-crypt] Fwd: Cannot wipe header on device

Luís de Sousa luis.a.de.sousa at gmail.com
Tue Dec 15 09:53:39 CET 2015

Hello again,

I have just consulted the mail list archive and it seems I am only
recieving a restricted number of replies to this thread. You can find
the smartctl output at the end of this message; it essentially says
nothing. Regarding system messages, I am not getting anything beyond
those I already posted here.

Yesterday I ran badblocks again in read-write mode; it took over 8
hours to complete and reported zero errors. The only new thing is the
output from fsck, that is reporting "Bad magic number in super-block"
- see the full output below. I recieve the same error if try one of
the alternate superblocks suggested.

I thank you once more for your help, I really appreciate you keep it
going in this list.


$ sudo smartctl -A -d scsi /dev/sdb
smartctl 6.2 2013-07-26 r3841 [x86_64-linux-3.13.0-48-generic] (local build)
Copyright (C) 2002-13, Bruce Allen, Christian Franke, www.smartmontools.org

Elements in grown defect list: 0

$ sudo fsck /dev/sdb1
fsck from util-linux 2.20.1
e2fsck 1.42.9 (4-Feb-2014)
ext2fs_open2: Bad magic number in super-block
fsck.ext2: Superblock invalid, trying backup blocks...
fsck.ext2: Bad magic number in super-block while trying to open /dev/sdb1

The superblock could not be read or does not describe a valid ext2/ext3/ext4
filesystem.  If the device is valid and it really contains an ext2/ext3/ext4
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>
    e2fsck -b 32768 <device>

More information about the dm-crypt mailing list