[dm-crypt] External HD don't want to be deciphered

janemba cap.janemba at gmail.com
Tue May 5 20:47:28 CEST 2015

On 05/04/2015 08:59 PM, Sven Eschenberg wrote:
> On Mon, May 4, 2015 16:51, janemba wrote:
>> (Sorry I forgot the subject)
>> On Mon, May 4, 2015 at 4:50 PM, janemba <cap.janemba at gmail.com> wrote:
>>> Hi,
>>> I have an issue with LUKS. I have a new external hard drive with the
>>> following characteristics :
>>> Host scsi11: usb-storage
>>> Vendor: Seagate (2TB)
>>> Product: Expansion
>>> Serial Number: xxx
>>> Protocol: Transparent SCSI
>>> Transport: Bulk
>>> Quirks: SANE_SENSE
>>> Also I have cryptsetup install on my box with version 1.4.3 and kernel
>>> 3.14.5. I can't update cryptsetup on this box as I ciphered the hard
>>> drive
>>> with this version and I'm afraid to not be able to deciphered the hard
>>> drive if cryptsetup version change.
> On a short sidenote, you could still keep a copy of your current
> cryptsetup for safety or even compile a static build to keep on your
> 'desk' or some thumb drive just in case some issues arise with newer
> versions.
> Ragards
> -Sven
> P.S.: Aside from that you might want to fill in the details Arno asked for...

Ok thank you guys. I tried  with a static version of cryptsetup and
everything worked fine now. So, I will update to the latest
version like Arno said but after a complete backup.

Thanks again

More information about the dm-crypt mailing list