[dm-crypt] luksAddKey hangs for ~85 minutes and then fails

Milan Broz gmazyland at gmail.com
Tue Jun 21 05:24:38 CEST 2016

On 06/21/2016 12:15 AM, Joe Hillenbrand wrote:
> I've been trying and trying to add a new key to one of my devices so
> that I can automount,
> but it consistently fails.
> I run the following command. It hangs for ~85 minutes every time (I've
> tried at least 5 times)

Does it work if you just open the device? For example try

cryptsetup luksOpen /dev/md1 --test-passphrase

> and then fails with the "Not compatible PBKDF2 options" message and exit code 1.
>     $ sudo cryptsetup luksAddKey /dev/md1 /etc/.md1.key
>     Enter any existing passphrase:
>     Not compatible PBKDF2 options (using hash algorithm sha256).

Could you please send output with added --debug switch?

It is failing PBKDF2 benchmark here so please try and send output
of these commands as well:

cryptsetup benchmark -h sha256 --debug
cryptsetup benchmark -h sha1 --debug

What distro and version it is?
Do you compile anything (kernel, cryptsetup, library...) yourself?

> I've tried generating several different keys of different sizes.
> Exact same behavior for all of them.

Key format is not the problem here.


More information about the dm-crypt mailing list