[dm-crypt] configure: error: You need the uuid library.

Milan Broz gmazyland at gmail.com
Sun Mar 4 11:24:27 CET 2018


On 03/04/2018 04:26 AM, Rui Amaral wrote:
> checking uuid/uuid.h usability... no
> checking uuid/uuid.h presence... no
> checking for uuid/uuid.h... no
> configure: error: You need the uuid library.
> ............
> 
> Can you help me please?

Do not compile it yourself, Ubuntu and Debian has 2.0.1 in some repository already.

Otherwise you need some development libraries, in this case I think
it is uuid-dev. You will need more devel libraries though.

m.


More information about the dm-crypt mailing list